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ApSIC Xbench vous permet d'organiser votre terminologie de référence 
bilingue et d'y faire des recherches. ApSIC Xbench dispose également de 
plusieurs contrôles d'assurance qualité (QA) pour renforcer la qualité de 
vos traductions. 

Fonctions de recherche 

ApSIC Xbench vous permet d'effectuer des recherches complexes dans 
les formats bilingues suivants : 

� Fichiers texte délimité par des tabulations (*.txt) 

� Fichiers XLIFF (*.xlf, *.xlif, *.xliff) 

� Mémoires TMX (*.tmx) 

� Glossaires TBX / MARTIF (*.xml, *tbx, *.mtf) 

� Mémoires exportées Trados (*.txt) 

� Glossaires exportés Trados MultiTerm 5 (*.txt) 

� Glossaires Trados MultiTerm XML (*.xml) 

� Fichiers Trados TagEditor (*.ttx) 

� Fichiers non nettoyés Trados Word (*.doc, *.rtf) 

� Fichiers Trados Studio (*.sdlxliff, *.sdlproj) 

� Fichiers SDLX ITD (*.itd). Remarque : cette option nécessite que 
SDLX soit installé sur l'ordinateur.  

� Mémoires SDLX (*.mdb) 

� Arborescence de répertoires STAR Transit 2.6/XV 

� Fichiers PO (*.po) 

� Dictionnaires exportés IBM TranslationManager (*.sgm) 

� Dossiers installés et exportés IBM TranslationManager (*.fxp)  

� Mémoires exportées IBM TranslationManager (*.exp) 

� Dictionnaires exportés OpenTM2 (*.sgm) 

� Dossiers installés et exportés OpenTM2 (*.fxp)  

� Mémoires exportées OpenTM2 (*.exp) 

� Mémoires Wordfast (*.txt) 

� Glossaires Wordfast (*.txt) 

� Fichiers Wordfast Pro TXML 

� Fichiers DejaVu X / Idiom (*.wsprj, *.dvprj) 

� Mémoires DejaVu X / Idiom (*.wstm, *.dvmdb) 

Présentation 
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� Fichiers Logoport RTF (*.rtf) 

� Glossaires de logiciels Microsoft (*.csv) 

� Glossaires Mac OS X (*.ad) 

� Glossaires Remote Xbench Server 

Il est possible d'organiser la terminologie de référence selon plusieurs 
niveaux de priorité, afin d'afficher clairement les préférences particulières 
du projet de traduction.  

ApSIC Xbench s'exécute en arrière-plan et il est possible de lancer une 
recherche du texte actuellement sélectionné en utilisant une combinaison 
de touches disponible dans l'ensemble du système (par défaut 
Ctrl+Alt+Inser). Cette fonction permet d'effectuer efficacement des 
recherches terminologiques instantanées, à partir de n'importe quelle 
application Windows, à l'aide d'une simple combinaison de touches. 

ApSIC Xbench bénéficie d'un moteur de recherche très puissant. Non 
seulement vous pouvez rechercher dans le texte source ou le texte cible, 
mais vous pouvez également effectuer des recherches négatives ou 
conditionnelles avec la fonction PowerSearch (Ctrl+P), ou encore lancer 
des recherches complexes en utilisant la syntaxe des expressions 
régulières ou les caractères de remplacement Microsoft Word.  

Remarque : après son lancement, ApSIC Xbench reste à l'arrière-plan 
jusqu'à ce qu'il soit explicitement fermé avec la commande Shutdown 
Xbench, disponible dans le menu déroulant Project ou dans le menu 
contextuel qui s'affiche en cliquant avec le bouton droit sur l'icône de la 
zone de notification Windows.  

Fonctions QA 

En définissant vos fichiers de traduction actuels comme ongoing 
translation dans votre projet ApSIC Xbench, vous pouvez exécuter les 
contrôles QA suivants : 

� Détection des segments non traduits 

� Détection des segments avec le même texte source mais différents 
textes cible 

� Détection des segments avec le même texte cible mais différents 
textes source 

� Détecter des segments dont le texte cible est identique au texte source 
(potentiellement du texte non traduit) 

� Détecter les disparités du balisage 

� Détecter les disparités numériques 

� Détecter les doubles espaces 

� Détecter les répétitions de mot 

� Détecter les disparités terminologiques par rapport à une liste de mots 
clés 
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� Exécuter une liste de vérification définie par l'utilisateur 

� Vérifier l'orthographe des traductions (nécessite le téléchargement 
des dictionnaires linguistiques correspondants) 

Les listes de vérification sont des recherches définies par l'utilisateur que 
vous pouvez exécuter par lot sur votre traduction en cours. Par exemple, 
les listes de vérification vous permettent de détecter la présence de mots 
interdits ou des pièges de traduction typiques. 
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Installation et désinstallation 
d'ApSIC Xbench 

Pour installer ApSIC Xbench 

Pour installer ApSIC Xbench, procédez comme suit : 

Lancez l'exécutable d'installation (par exemple, Setup.Xbench.2.9.exe). 
L'écran de bienvenue de l'assistant d'installation s'affiche. 

 

Cliquez sur Next. La licence s'affiche dans une fenêtre. Veuillez lire 
attentivement les informations de licence pour vérifier que vous acceptez 
ses conditions. 

Si les conditions de la licence vous conviennent, veuillez cliquer sur I 
Agree. Dans le cas contraire, veuillez cliquer sur Cancel. 

C H A P I T R E  1  
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Le cas échéant, modifiez le dossier d'installation du programme et cliquez 
sur Install  pour continuer. 

Les fichiers sont copiés dans le dossier de destination et la fenêtre 
suivante s'affiche. 

 

Cliquez sur Finish pour fermer l'assistant d'installation et lancer ApSIC 
Xbench. 

Un raccourci vers l'exécutable d'ApSIC Xbench a été placé dans le menu 
Démarrer->Programmes->ApSIC Tools->Xbench, ainsi que d'autres 
raccourcis pour la documentation. 
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Pour désinstaller ApSIC 
Xbench 

Pour désinstaller ApSIC Xbench, procédez comme suit : 

1 Cliquez sur le menu Démarrer->Paramètres->Panneau de 
configuration dans la barre des tâches Windows. Dans le Panneau de 
configuration, cliquez sur l'icône Ajout/Suppression de 
programmes. 

2 Cherchez ApSIC Xbench dans la liste et cliquez sur le bouton 
Modifier/Supprimer . 

3 À l'affichage du message de confirmation, cliquez sur Oui. 
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Lancement et fermeture 
d'ApSIC Xbench 

ApSIC Xbench est une application qui, une fois lancée, doit être 
explicitement fermée lorsque vous n'en avez plus besoin. Dans un 
scénario normal, vous chargez votre projet de référence pour effectuer 
des recherches terminologiques pendant votre traduction et vous laissez 
l'application en arrière-plan jusqu'à ce que vous finissiez votre travail de 
traduction. La simple fermeture de la fenêtre ApSIC Xbench ne ferme pas 
le programme en mémoire, parce qu'il attend votre prochaine requête 
avec la combinaison de touches Ctrl+Alt+Inser. 

Lancement d'ApSIC 
Xbench 

Pour lancer ApSIC Xbench, utilisez l'une des procédures suivantes : 

� Cliquez sur le menu Démarrer->Programmes->ApSIC Tools-
>Xbench dans la barre des tâches Windows. 

� Double-cliquez sur l'icône d'un projet ApSIC Xbench précédemment 
sauvegardé (extension .xbp). 

Fermeture d'ApSIC 
Xbench 

Pour fermer ApSIC Xbench, utilisez l'une des procédures suivantes : 

� Cliquez avec le bouton droit sur l'icône d'ApSIC Xbench (une gemme 
rose) située dans la zone de notification, puis cliquez sur Shutdown 
Xbench dans le menu contextuel. 

� Dans le menu Project, cliquez sur Shutdown Xbench. 
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Dans cette section, vous allez apprendre à utiliser les fonctions de 
recherche d'ApSIC Xbench. Les concepts suivants vous seront utiles pour 
comprendre le fonctionnement d'ApSIC Xbench : 

Project : dans ApSIC Xbench, un « projet » définit un ensemble de 
fichiers, leurs priorités et leurs relations. La première chose à faire dans 
ApSIC Xbench est de définir un projet qui regroupe la terminologie dans 
laquelle vous souhaitez effectuer des recherches, puis de configurer les 
modalités de cette recherche. 

Ongoing translation : ApSIC Xbench vous laisse marquer un fichier ou un 
ensemble de fichiers comme « traduction en cours », ce qui permet 
ensuite d'identifier visuellement leurs segments dans les résultats de 
recherche. En outre, les fonctions QA ne peuvent être exécutées que sur 
les fichiers définis comme traduction en cours. 

Checklist : dans ApSIC Xbench, une « liste de vérification » est un 
ensemble de recherches qui sont exécutées par lot. 

PowerSearch : c'est un mode de recherche spéciale qui vous permet de 
définir des conditions ET/OU et des négations sur des chaînes de 
caractères, afin d'effectuer des recherches complexes. C'est une fonction 
très utile pour toutes les activités associées à l'assurance qualité. 

Regular Expression : une « expression régulière » est une chaîne de 
recherche contenant des caractères spéciaux dotés de significations 
spécifiques, qui vous permet d'identifier de façon concise et souple des 
modèles de caractères et de mots. La syntaxe des expressions régulières 
respecte les normes en vigueur. C'est l'un des modes de recherche et de 
contrôle QA d'ApSIC Xbench. 

Microsoft Word Wildcard : ApSIC Xbench vous permet également 
d'effectuer des recherches en utilisant les « caractères de remplacement 
Microsoft Word », qui respectent une syntaxe similaire à celle des 
expressions régulières, mais dans une version alternative simplifiée. 
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Définition d'un projet de 
recherche 

La première étape pour utiliser les puissantes fonctions de recherche 
d'ApSIC Xbench consiste à définir les sources de référence de votre 
projet. Pour ce faire, ajoutez les fichiers et les répertoires nécessaires dans 
votre projet en sélectionnant la commande de menu Project->Properties 
ou en appuyant sur la touche F2. La boîte de dialogue Project Properties 
s'affiche comme illustré sur la capture d'écran ci-dessous. 

 

Cliquez sur le bouton Add pour ajouter des fichiers à votre projet. 

Sélectionnez le type de fichier à ajouter au projet d'ApSIC Xbench : 
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ApSIC Xbench prend en charge les types de fichier suivants : 

� Tab-delimited Text File (*.txt). Un fichier dans lequel chaque ligne est 
constitué d'un certain nombre de champs délimités par le caractère 
tabulation. Le premier champ et le deuxième champ d'une entrée sont 
considérés respectivement comme la source et la cible. Les champs 
additionnels sont considérés comme descriptifs et leur nombre n'est 
pas limité. 

� XLIFF File (*.xlf, *.xlif, *.xliff). Un fichier compatible avec la norme 
XLIFF. 

� TMX Memory (*.tmx). Un fichier compatible avec la norme TMX. La 
plupart des outils de traduction sont capables de générer des 
mémoires TMX, avec des niveaux de conformité variables. 

� TBX/MARTIF Glossary (*.xml, *.tbx, *.mtf). Un fichier compatible avec 
la norme TBX ou MARTIF. 

� Trados Exported Memory (*.txt). Une mémoire Trados au format .txt, 
exportée depuis Trados. 

� Trados Exported MultiTerm 5 Glossary (*.txt). Un glossaire MultiTerm 
exporté dans un fichier .txt, où chaque entrée est délimitée par une 
ligne contenant deux astérisques (**). 

� Trados MultiTerm XML Glossary (*.xml). Un glossaire MultiTerm 
exporté au format XML. 

� Trados TagEditor File (*.ttx). Un fichier au format Trados TagEditor. 

� Trados Word File (*.doc, *.rtf). Un fichier au format Trados Word, 
contenant des segments bilingues. 

� Trados Studio File (*.sdlxliff, *.sdlproj). Un fichier au format Trados 
Studio. Lorsqu'un fichier de projet Trados Studio (*.project) est 
sélectionné, ApSIC Xbench ouvre les fichiers sdlxilff indiqués dans 
le fichier de projet, pour la première paire de langues mentionnée 
dans le fichier de projet. 

� SDLX File (*.itd). Un fichier individuel SDLX, ou bien un répertoire et 
ses éventuels sous-répertoires contenant des fichiers SDLX. 
Remarque : cette option nécessite que SDLX soit installé sur 
l'ordinateur.  

� SDLX Memory (*.mdb). Un fichier individuel SDLX contenant une 
mémoire de traduction. 

� STAR Transit 2.6/XV Directory Tree. Un répertoire qui contient les 
paires de fichiers Transit. Veuillez noter qu'ApSIC Xbench ne prend 
pas en charge les paires de fichiers STAR Transit NXT. 

� PO File. Un fichier .po bilingue, généralement créé avec la 
bibliothèque d'internationalisation Gettext. 

� IBM TM/OpenTM2 Dictionary (*.sgm). Un dictionnaire IBM 
TranslationManager au format SGML. Ce fichier possède l'extension 
.sgm. 
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� IBM TM/OpenTM2 Folder. Un répertoire IBM TranslationManager 
installé sur votre système. Ce format peut être défini comme 
traduction en cours, afin d'une part de faire une distinction nette entre 
les nouvelles et les anciennes traductions, et d'autre part d'afficher les 
segments non traduits pour prendre les meilleures décisions sur la 
nouvelle terminologie. 

� IBM TM/OpenTM2 Exported Folder (*.fxp). Un répertoire IBM 
TranslationManager exporté au format FXP. 

� IBM TM/OpenTM2 Exported Memory (*.exp). Un répertoire IBM 
TranslationManager exporté au format EXP. 

� Wordfast Memory (*.txt). Une mémoire Wordfast avec l'extension .txt. 

� Wordfast Glossary (*txt). Un glossaire Wordfast avec l'extension .txt. 

� Wordfast Pro TXML (*.txml). Un fichier bilingue Wordfast Pro avec 
l'extension .txml. 

� DejaVu X/Idiom File (*.wsprj, *.dvprj). Une base de données DejaVu ou 
Idiom contenant les fichiers de traduction d'un projet, avec l'extension 
.dvprj ou .wsprj. 

� DejaVu X/Idiom Memory (*.wstm, *.dvmdb). Un mémoire de traduction 
DejaVu ou Idiom avec l'extension .dvmdb ou .wstm. 

� Logoport RTF (*.rtf). Un fichier individuel Logoport ou bien un 
répertoire contenant des fichiers Logoport. 

� Microsoft Glossary (*.csv). Un glossaire de logiciel Microsoft, 
distribué par Microsoft via MSDN, et contenant toutes les chaînes de 
caractères d'un logiciel Microsoft. 

� Mac OS X Glossary (*.ad). Un fichier au format XML d'Apple, 
librement téléchargeable depuis Internet. 

� Remote Xbench Server. Une référence à un serveur distant ApSIC 
Xbench. 

Après cette sélection et en fonction du type de fichier choisi, l'onglet 
Folder List  ou File List  s'affiche pour vous permettre d'ajouter plusieurs 
entrées du type sélectionné. En fonction du type de fichier choisi, cliquez 
sur le bouton Add..., Add File... ou Add Folder... pour ajouter des 
entrées à la liste. 

À partir de là, les fenêtres affichées diffèrent en fonction du type de 
fichier sélectionné. Dans le tableau ci-dessous, suivez les instructions 
correspondant au type de fichier sélectionné, étape par étape. 
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Si vous ajoutez... Suivez ces étapes : 

Tab-delimited text file, XLIFF 
file, TMX memory, Trados 
Exported memory, Trados Tag 
Editor file, Trados Word file, 
Trados Studio file, SDLX file, 
SDLX Memory, PO file, IBM 
TM/OpenTM2 Dictionary, IBM 
TM/OpenTM2 Exported folder, 
IBM TM/OpenTM2 Exported 
memory, Wordfast memory, 
Wordfast glossary, Wordfast Pro 
TXML, Microsoft glossary, Mac 
OS X glossary, Deja Vu X/Idiom 
file, Deja Vu/Idiom Memory, 
Logoport RTF file 

1 L'onglet File/Folder List  
s'affiche. Cliquez sur le 
bouton Add File ou Add 
Folder pour ajouter des 
fichiers ou des dossiers du 
type sélectionné. Les dossiers 
s'affichent en gras dans la 
liste. 

2 Cliquez sur Next dans l'onglet 
File/Folder List pour afficher 
l'onglet Properties. 

3 Configurez les propriétés 
requises et cliquez sur OK  
pour terminer. Remarque : si 
vous avez ajouté un dossier à 
l'étape 1, cliquez sur Next 
pour afficher un onglet 
supplémentaire qui vous 
permettra de préciser, en 
cochant la case Recurse 
Directories, si vous souhaitez 
inclure les fichiers du même 
type situés dans les sous-
dossiers. 

STAR Transit directory tree 1 L'onglet Folder List  s'affiche, 
ouvrant automatiquement la 
boîte de dialogue Select 
Directory . Sélectionnez le 
répertoire contenant les 
fichiers que vous souhaitez 
ajouter au projet ApSIC 
Xbench. 

2 Cliquez sur Next dans l'onglet 
File List  pour afficher l'onglet 
Properties. 

3 Configurez les propriétés 
requises pour le répertoire 
concerné, puis cliquez sur 
Next pour afficher l'onglet 
Directory Settings. 

4 Dans l'onglet Directory 
Settings, vous pouvez cocher 
la case Recurse Directories 
pour qu'ApSIC Xbench 
recherche également des 
fichiers du type concerné dans 
les sous-répertoires. 
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Trados exported MultiTerm 5 
glossary, Trados MultiTerm XML 
ou TBX/MARTIF 

1 L'onglet File List  s'affiche, 
ouvrant automatiquement la 
boîte de dialogue Add 
Glossary. Sélectionnez tous 
les fichiers du type concerné 
dans la fenêtre. Si vous devez 
sélectionner d'autres fichiers 
situés dans un autre répertoire, 
lorsque vous êtes de retour 
dans l'onglet File List , cliquez 
sur le bouton Add pour rouvrir 
la fenêtre Add Glossary. 

2 Cliquez sur Next dans l'onglet 
File List  pour afficher l'onglet 
Properties. 

3 Configurez les propriétés 
requises pour le fichier 
concerné, puis cliquez sur 
Next pour afficher l'onglet 
MultiTerm XML . 

4 Dans l'onglet MultiTerm 
XML , sélectionnez la langue 
source et la langue cible dans 
la liste proposée, puis cliquez 
sur OK  pour terminer. 

IBM TM/OpenTM2 Folder 1 L'onglet Folder List  s'affiche, 
ouvrant automatiquement la 
boîte de dialogue Open IBM 
TM/OpenTM2 Folder . Si 
nécessaire, basculez sur le 
disque contenant votre dossier 
IBM TM ou OpenTM2, puis 
sélectionnez le ou les dossiers 
dans la liste affichée. 

2 Cliquez sur Next dans l'onglet 
File List  pour afficher l'onglet 
Properties. 

3 Configurez les propriétés 
requises et cliquez sur OK  
pour terminer. 

Remote Xbench Server 1 Configurez les propriétés 
requises, puis cliquez sur Next 
pour afficher l'onglet Remote 
Xbench Server. 

2 Attribuez un nom à la 
connexion et indiquez l'URL 
du serveur Xbench. 
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Après être revenu dans la fenêtre Project Properties, vous pouvez 
ajouter d'autres fichiers ou répertoires en suivant la procédure précédente. 

Lorsque vous avez terminé, cliquez sur OK  dans la fenêtre Project 
Properties pour revenir dans la fenêtre principale d'ApSIC Xbench. 
ApSIC Xbench chargera ensuite les glossaires dans l'environnement de 
travail. 

Ensuite, dans le menu Project, cliquez sur Save as pour enregistrer ce 
nouvel ensemble de glossaires dans votre répertoire, avec les autres 
projets ApSIC Xbench. Il est recommandé d'enregistrer les fichiers de 
projet avec des noms significatifs pour leur future réutilisation.  

Remarque : lors de son prochain lancement, ApSIC Xbench chargera 
automatiquement le dernier projet ouvert, sauf si cette fonction a été 
désactivée dans Tools->Settings->Miscellaneous Settings. 
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Recherche terminologique 

ApSIC Xbench dispose d'un moteur de recherche très puissant. Par 
exemple, vous pouvez rechercher des termes dans le texte source, dans le 
texte cible ou dans les deux à la fois. ApSIC Xbench vous permet 
également de faire des recherches en utilisant des expressions régulières 
ou des caractères de remplacement Microsoft Word, et de les combiner 
en utilisant le mode PowerSearch. 

 

La plupart de vos recherches porteront probablement sur le texte source. 
Cependant, vous n'aurez généralement pas besoin de rechercher un terme 
lorsque vous êtes dans l'interface d'ApSIC Xbench, mais plutôt pendant 
votre traduction dans Word ou dans une autre application de TAO comme 
Trados Translator’s Workbench, SDLX, IBM TranslationManager, 
DejaVu, ou encore depuis un courrier dans votre programme de 
messagerie comme Microsoft Outlook ou Mozilla Thunderbird. 

C'est pourquoi ApSIC Xbench est accessible dans l'ensemble du système, 
à partir de n'importe quelle application, grâce à une simple combinaison de 
touches (Ctrl+Alt+Inser). 

Les 5 étapes suivantes décrivent la manière d'interagir avec ApSIC 
Xbench. Le point de départ de ce scénario est un document ouvert au 
premier plan dans Microsoft Word, et un projet ApSIC Xbench chargé en 
arrière-plan. 

1 Dans Microsoft Word, sélectionnez le terme (en totalité ou en partie) 
que vous souhaitez rechercher.  

C H A P I T R E  4  
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2 Dans Microsoft Word, appuyez sur la combinaison de touches 
Ctrl+Alt+Inser pour appeler ApSIC Xbench. Cette action lance 
automatiquement la recherche du terme sélectionné. Cette 
combinaison de touches est la plus importante à connaître pour 
utiliser ApSIC Xbench.  

3 ApSIC Xbench présente les résultats de la requête comme illustré sur 
la capture d'écran ci-dessus. 

Vous pouvez définir jusqu'à trois niveaux de priorité, un niveau vert 
(priorité haute), un niveau marron (priorité moyenne) et un niveau 
bleu (priorité basse). La colonne étiquetée # indique le nombre 
d'occurrences détectées dans le fichier, qui ont été regroupées dans 
l'entrée correspondante affichée dans la fenêtre. 

Le point vert  situé devant le terme cible indique que l'entrée 
correspond exactement (casse comprise) au terme recherché. Si un 
point jaune  s'affiche devant le terme cible, cela signifie que l'entrée 
correspond au terme recherché sauf en ce qui concerne la casse. Par 
exemple, dans l'exemple ci-dessus, si nous avions recherché le terme 
« Clipboard » au lieu de « clipboard », le point aurait été vert au lieu 
de jaune, parce que la casse du terme recherché aurait été exactement 
la même que celle du terme détecté dans le fichier. 

Lors de la traduction d'une documentation, cette indication est 
particulièrement utile parce que vous pouvez copier-coller le terme 
cible exact, ce qui vous rend plus productif et plus précis. La 
procédure suivante décrit le mode de fonctionnement de cette 
fonction. 

4 Si vous souhaitez copier dans le presse-papiers le terme cible de 
l'entrée actuellement sélectionnée, appuyez simplement sur la touche 
Entrée pour fermer la fenêtre ApSIC Xbench. ApSIC Xbench est 
alors masqué et vous revenez dans l'application d'origine (dans cet 
exemple, Microsoft Word). 

Remarque : si vous préférez ne rien copier dans le presse-papiers, 
appuyez sur la touche Echap ou sur la combinaison de touches Alt+F4 
pour masquer ApSIC Xbench et revenir dans Microsoft Word. 

5 Si vous avez choisi de masquer la fenêtre ApSIC Xbench avec la 
touche Entrée et, par conséquent, d'enregistrer le terme cible dans le 
presse-papiers, il vous suffit d'appuyer sur la combinaison de touches 
Maj+Inser pour copier le terme cible dans votre document. 

Vous remarquerez que, notamment pour les commandes logicielles, il est 
plus rapide de rechercher-coller que de saisir manuellement des 
commandes du logiciel cible. Par conséquent, vous êtes plus productif et 
vos traductions sont en même temps plus homogènes. 

Astuce : familiarisez-vous avec la procédure ci-dessus jusqu'à ce qu'elle 
devienne suffisamment intuitive. Essayez d'abord avec des mots connus 
pour vous habituer à l'étape de collage. 
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Expressions régulières et 
caractères de remplacement 
Microsoft Word 

ApSIC Xbench vous permet d'effectuer des recherches complexes en 
utilisant les expressions régulières ou les caractères de remplacement 
Microsoft Word. Pour activer ces modes de recherche, procédez comme 
suit : 

1. Sélectionnez la commande de menu View->Search Options pour 
afficher le panneau des options de recherche. 

2. Sélectionnez la liste déroulante Search Mode et choisissez Regular 
Expressions ou MS Word Wildcards . 

3. Vous verrez alors apparaître une icône à côté des champs Source 
Term et Target Term, qui vous indique clairement le mode sélectionné. 

Syntaxe des expressions régulières 

Caractère ou 
expression 

Signification Exemples 

. N'importe quel caractère Jo.n trouvera John et Joan, mais pas Johan. 

* 0 ou plusieurs instances du caractère 
précédent 

Joh*n trouvera Jon, John et Johhn, mais ne 
trouvera pas Johan. 

Remarque : dans les expressions régulières, 
l'astérisque n'a pas la même signification 
qu'avec les caractères de remplacement 
Microsoft Word. Pour signifier n'importe quel 
nombre de caractères, vous devez utiliser la 
séquence point-astérisque (.*). Par exemple, 
Joh.*n trouvera John, Johhn et Johan (mais ne 
trouvera pas Jon). 

? 0 ou 1 instance du caractère précédent Joh?n trouvera Jon et John, mais ne trouvera 
pas Johan. 

+ 1 ou plusieurs répétitions du caractère 
précédent 

Joh+n trouvera John et Johhn, mais ne trouvera 
pas Jon ou Johan. 

{m} Exactement m répétitions du caractère 
précédent 

Joh{2}n trouvera Johhn, mais ne trouvera pas 
Jon, John ou Johhhn. 
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{m,} m ou plusieurs répétitions du caractère 
précédent 

Joh{2,}n trouvera Johhn et Johhhn, mais ne 
trouvera pas Jon ou John. 

{,n} 1 à n répétitions du caractère précédent Joh{,2}n trouvera John et Johhn, mais ne 
trouvera pas Jon ou Johhhn. 

{m,n} m à n répétitions du caractère précédent Joh{1,2}n trouvera John et Johhn, mais ne 
trouvera pas Jon ou Johhhn. 

< Début de mot <Phon trouvera Phone, mais ne trouvera pas 
iPhone. 

> Fin de mot hones> trouvera Phones, mais ne trouvera pas 
Phone. 

Remarque : pour rechercher un mot entier, vous 
pouvez indiquer soit <Phone> pour trouver 
Phone mais pas Phones ou iPhone, soit 
<Phones*> pour trouver à la fois Phone et 
Phones mais pas iPhone ou iPhones. 

^ Début de ligne (doit être au début de 
l'expression) 

^Phone trouvera toutes les lignes qui 
commencent par Phone. 

$ Fin de ligne (doit être à la fin de 
l'expression) 

received$ trouvera toutes les lignes qui se 
terminent par received. 

\ Caractère d'échappement. Le caractère 
qui suit sera considéré comme un 
simple caractère. 

phone\. trouvera toutes les entrées qui 
présentent un point après le mot phone. (Dans 
ce cas, le point ne signifie pas « n'importe quel 
caractère » puisqu'il est échappé.) 

% Rend le caractère ou l'expression qui 
précède insensible à la casse. Lorsque le 
mode de recherche d'ApSIC Xbench est 
sensible à la casse, cet argument peut 
être utilisé pour rendre cette partie de la 
chaîne recherchée insensible à la casse. 

Dans le mode de recherche d'ApSIC Xbench 
sensible à la casse, a% trouvera a et A. De 
même, P(hone)% trouvera Phone et PHONE, 
mais ne trouvera pas phone parce que dans ce 
dernier cas, la lettre p n'est pas incluse dans 
l'expression concernée par l'argument. 

\xnn Le caractère spécifié par nn, où nn est 
un nombre hexadécimal. 

\x48\x6f\x77\x64\x79\x3f trouvera Howdy?. 

| Opérateur OU ^H|I trouvera toutes les phrases qui commencent 
par un H ou par un I. 

( ) Opérateur parenthèse servant à indiquer 
la priorité de traitement 

(^H)|I trouvera toutes les phrases qui 
commencent par un H ou qui contiennent un I. 
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[set-expression] Un caractère appartenant à la série 
définie par set-expression. Une série se 
définit comme un ensemble de 
caractères individuels (par exemple, 
[aeiou]) et/ou comme une plage de 
caractères délimitée par un caractère de 
début et un caractère de fin (par 
exemple, [a-z]). 

File[0-9]  trouvera File0, File1, File2, ... File9, 
mais ne trouvera pas FileX. 

File[ABC] trouvera FileA, FileB et FileC, mais 
ne trouvera pas FileD. 

[:special-set:] Un caractère appartenant à une série 
prédéfinie special-set. Les séries 
spéciales suivantes sont prédéfinies 
dans ApSIC Xbench : [:space:], 
[:control:], [:punctuation:], [:punct:], 
[:separator:], [:sep:], [:symbol:], 
[:alpha:], [:num:], [:xdigit:], 
[:alphanum:], [:letter:], [:digit:], 
[:letterdigit:], [:number:]. Une série 
spéciale doit être utilisée dans une série 
set-expression (par exemple [:digit:]). 
Les caractères correspondants à chaque 
série spéciale sont listés dans la section 
Séries spéciales (à la page 29). 

File[:digit:]  trouvera File0, File1 ou File2, mais 
ne trouvera pas FileA ou FileB. 

File[:alpha:][:digit:]  trouvera FileA0, FileB1 
ou FileC2, mais ne trouvera pas File1A ou 
File2B. 

[^set-
expression] 

N'importe quel caractère n'appartenant 
pas à la série set-expression. 

File[^ABC] trouvera FileD ou FileE, mais ne 
trouvera pas FileA, FileB et FileC. 

(expression)=n Assigne à la variable n la valeur 
calculée d'expression dans le segment 
en cours de traitement. La valeur 
calculée peut être rappelée avec 
l'expression @n. 

(File[0-9])=1  définit la variable 1 comme 
valeur calculée de File[0-9]  

@n Renvoie la valeur calculée de la variable 
n. 

@1 dans l'exemple ci-dessus renverrait la chaîne 
File1 si la chaîne recherchée contenait File1, 
File2 si elle contenait File2, et ainsi de suite. 

 

Syntaxe des caractères de remplacement Microsoft Word 

Caractère ou 
expression 

Signification Exemples 

. N'importe quel caractère Jo.n trouvera John et Joan, mais pas Johan. 

0 ou plusieurs caractères Joh*n trouvera John, Johan et Johhn, mais ne 
trouvera pas Jon. 

? 0 ou 1 caractère Jo?n trouvera Jon, John et Joan, mais pas 
Johan. 
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@ 1 ou plusieurs répétitions du caractère 
précédent 

Joh@n trouvera John et Johhn, mais ne trouvera 
pas Jon ou Johan. 

{m} Exactement m répétitions du caractère 
précédent 

Joh{2}n trouvera Johhn, mais ne trouvera pas 
Jon, John ou Johhhn. 

{m,} m ou plusieurs répétitions du caractère 
précédent 

Joh{2,}n trouvera Johhn et Johhhn, mais ne 
trouvera pas Jon ou John. 

{,n} 1 à n répétitions du caractère précédent Joh{,2}n trouvera John et Johhn, mais ne 
trouvera pas Jon ou Johhhn. 

{m,n} m à n répétitions du caractère précédent Joh{1,2}n trouvera John et Johhn, mais ne 
trouvera pas Jon ou Johhhn. 

< Début de mot <Phon trouvera Phone, mais ne trouvera pas 
iPhone. 

> Fin de mot hones> trouvera Phones, mais ne trouvera pas 
Phone. 

Remarque : pour rechercher un mot entier, vous 
pouvez indiquer soit <Phone> pour trouver 
Phone mais pas Phones ou iPhone, soit 
<Phones*> pour trouver à la fois Phone et 
Phones mais pas iPhone ou iPhones. 

^ Début de ligne (doit être au début de 
l'expression) 

^Phone trouvera toutes les lignes qui 
commencent par Phone. 

$ Fin de ligne (doit être à la fin de 
l'expression) 

received$ trouvera toutes les lignes qui se 
terminent par received. 

\ Caractère d'échappement. Le caractère 
qui suit sera considéré comme un 
simple caractère. 

phone\. trouvera toutes les entrées qui 
présentent un point après le mot phone. (Dans 
ce cas, le point ne signifie pas « n'importe quel 
caractère » puisqu'il est échappé.) 

\xnn Le caractère spécifié par nn, où nn est 
un nombre hexadécimal. 

\x48\x6f\x77\x64\x79\x3f trouvera Howdy?. 

| Opérateur OU ^H|I trouvera toutes les phrases qui commencent 
par un H ou par un I. 

( ) Opérateur parenthèse servant à indiquer 
la priorité de traitement 

(^H)|I trouvera toutes les phrases qui 
commencent par un H ou qui contiennent un I. 
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[set-expression] Un caractère appartenant à la série 
définie par set-expression. Une série se 
définit comme un ensemble de 
caractères individuels (par exemple, 
[aeiou]) et/ou comme une plage de 
caractères délimitée par un caractère de 
début et un caractère de fin (par 
exemple, [a-z]). 

File[0-9]  trouvera File0, File1, File2, ... File9, 
mais ne trouvera pas FileX. 

File[ABC] trouvera FileA, FileB et FileC, mais 
ne trouvera pas FileD. 

[:special-set:] Un caractère appartenant à une série 
prédéfinie special-set. Les séries 
spéciales suivantes sont prédéfinies 
dans ApSIC Xbench : [:space:], 
[:control:], [:punctuation:], [:punct:], 
[:separator:], [:sep:], [:symbol:], 
[:alpha:], [:num:], [:xdigit:], 
[:alphanum:], [:letter:], [:digit:], 
[:letterdigit:], [:number:]. Une série 
spéciale doit être utilisée dans une série 
set-expression (par exemple [:digit:]). 
Les caractères correspondants à chaque 
série spéciale sont listés dans la section 
Séries spéciales (à la page 29). 

File[:digit:]  trouvera File0, File1 ou File2, mais 
ne trouvera pas FileA ou FileB. 

File[:alpha:][:digit:]  trouvera FileA0, FileB1 
ou FileC2, mais ne trouvera pas File1A ou 
File2B. 

[!set-expression] N'importe quel caractère n'appartenant 
pas à la série set-expression. 

File[!ABC]  trouvera FileD ou FileE, mais ne 
trouvera pas FileA, FileB et FileC. 

(expression)=n Assigne à la variable n la valeur 
calculée d'expression dans le segment 
en cours de traitement. La valeur 
calculée peut être rappelée avec 
l'expression \n. 

(File[0-9])=1  définit la variable 1 comme 
valeur calculée de File[0-9]  

\n Renvoie la valeur calculée de la variable 
n. 

\1 dans l'exemple ci-dessus renverrait la chaîne 
File1 si la chaîne recherchée contenait File1, 
File2 si elle contenait File2, et ainsi de suite. 
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Séries spéciales 

Le tableau suivant détaille les caractères correspondants aux séries 
spéciales qui peuvent être utilisées dans les expressions régulières et avec 
les caractères de remplacement Microsoft Word : 

Série spéciale Caractères correspondants à la série spéciale 

[:alpha:] N'importe quel caractère considéré comme 
alphabétique par le système d'exploitation, 
conformément à la page de code ANSI en vigueur. 

[:alphanum:] N'importe quel caractère considéré comme 
alphanumérique par le système d'exploitation, 
conformément à la page de code ANSI en vigueur. 

[:control:] Caractères de la plage hexadécimale 0x00-0x19. 

[:digit:] N'importe quel chiffre de '0' à '9'. 

[:letter:] Synonyme de la série [:alpha:]. 

[:letterdigit:] Synonyme de la série [:alphanumeric:]. 

[:num:], 
[:number:] 

N'importe quel chiffre de '0' à '9', ainsi que les 
fractions et les exposants suivants : '¹', '²', '³', '¼', '½', 
'¾' 

[:punct:], 
[:punctuation:] 

N'importe lequel des caractères suivants : ! " # % & 
' ( ) * , - . / : ; ? @ [ \ ] _ { } ¡ « - · » ¿ 

[:sep:], 
[:separator:] 

Espace (Hex 0x20) et espace insécable (Hex 0xA0) 

[:symbol:] N'importe lequel des caractères suivants : $ + <=> ^ 
` | ~ ¢ £ ¤ ¥ ¦ § ¨ © ¬ ® ¯  ° ± ´ ¶ ¸ × ÷ 

[:space:] Espace (Hex 0x20), tabulation et retour chariot de 
la plage Hex 0x09-0x0C, plus les caractères Hex 
0x85 et Hex 0xA0. 

[:xdigit:] N'importe quel chiffre hexadécimal de '0' à '9' et de 
'a' à 'f' (ou de 'A' à 'F'). 
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Fonctionnalités avancées 

ApSIC Xbench dispose de plusieurs fonctionnalités avancées que vous 
allez apprécier si vous avez des besoins spécifiques. Elles sont décrites 
dans les sections suivantes. 

Fonction PowerSearch 

Vous pouvez utiliser la combinaison de touches Ctrl+P (PowerSearch) 
pour effectuer une recherche avec des critères plus complexes. La 
fonction PowerSearch vous permet de rechercher des entrées :  

� Qui contiennent deux ou plusieurs chaînes de caractères, mais pas 
nécessairement les unes côté des autres. 

� Qui ne contiennent pas une chaîne donnée. 

� Qui contiennent une chaîne ou une autre chaîne. 

� N'importe quelle combinaison des conditions ci-dessus. 

Exemples : 

Cette expression... ...fait ce qui suit 

chaîne1 chaîne2 Trouvera toutes les entrées qui contiennent 
« chaîne1 » et « chaîne2 ». 

chaîne1 or chaîne2 Trouvera toutes les entrées qui contiennent 
« chaîne1 » ou « chaîne2 ». 

chaîne1 -chaîne2 Trouvera toutes les entrées qui contiennent 
« chaîne1 » mais qui ne contiennent pas 
« chaîne2 ». 

chaîne1 -"chaîne2 avec des 
espaces" 

Trouvera toutes les entrées qui contiennent 
« chaîne1 » mais qui ne contiennent pas 
« chaîne2 avec des espaces ». 

Dans les expressions plus complexes impliquant plusieurs chaînes avec 
des opérateurs booléens et/ou des relations, vous pouvez utiliser des 
parenthèses pour indiquer les priorités de traitement. 

En mode PowerSearch, vous devez utiliser les guillemets anglais « " » 
comme délimiteurs si votre expression contient des espaces ou des 
parenthèses. Si votre chaîne de recherche contient elle-même un 
guillemet anglais, vous devez le doubler pour l'échapper, c'est-à-dire 
utiliser deux guillemets anglais successifs « "" ». 
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Remarque : si l'un des mots à trouver en mode PowerSearch est le mot 
« or », vous devez l'encadrer avec des guillemets anglais « "or" » pour 
éviter qu'il ne soit traité comme l'opérateur booléen « OR ». 

La fonction PowerSearch peut être utilisée avec n'importe quel mode de 
recherche : simple, expressions régulières et caractères de 
remplacement Microsoft Word. 

Zoom 

ApSIC Xbench dispose de 3 types de zoom : 

� Zoom to Priority Level 

� Zoom to Glossary 

� Zoom to File 

Comme vous l'avez déjà remarqué, ApSIC Xbench affiche un aperçu des 
termes les plus appropriés pour chaque niveau de priorité, dans une seule 
fenêtre unifiée. Cela vous permet d'examiner les sources d'incohérences 
potentielles ou même de différentes significations, et de choisir un terme 
en toute connaissance de cause. 

Cependant, il est possible que vous souhaitiez afficher plusieurs ou toutes 
les entrées d'un niveau de priorité particulier, pour analyser de manière 
plus approfondie un terme spécifique. 

Dans ce cas, double-cliquez dans la fenêtre sur le niveau de priorité dans 
lequel vous souhaitez zoomer pour afficher la liste entière des entrées 
pour le terme recherché. L'arrière-plan prend la couleur verte et vous 
indique que vous êtes en mode zoom. 

Pour quitter le mode zoom, double-cliquez à nouveau dans la fenêtre. 

Recherche inverse 

ApSIC Xbench dispose également d'une fonction disponible dans 
l'ensemble du système vous permettant de rechercher un terme dans la 
colonne cible au lieu de la colonne source. La combinaison de touches 
par défaut de cette fonction est Ctrl+Alt+Retour arrière. 

Cela revient à laisser le champ Source Term vide et le champ Target 
Term rempli. 

Par exemple, cette fonction est utile lorsque vous souhaitez utiliser un 
nouveau terme dans votre langue et que vous voulez vous assurer que ce 
terme n'est pas déjà utilisé dans une autre expression, ce qui pourrait 
ultérieurement entraîner un problème dans la terminologie de votre projet. 
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Recherche circonscrite à la 
traduction en cours 

Dans le panneau Search Options, vous pouvez cocher la case Only 
Ongoing Translation pour limiter la recherche uniquement aux fichiers 
définis comme traduction en cours. C'est utile lorsque vous ajoutez votre 
traduction en cours au projet ApSIC Xbench, et que vous souhaitez réaliser 
une opération globale de rechercher-remplacer dans ladite traduction. 

Recherche circonscrite aux 
nouveaux segments 

Dans le panneau Search Options, vous pouvez cocher la case New 
Segments Only pour limiter la recherche uniquement aux segments 
considérés comme nouveaux. C'est utile lorsque vous avez besoin de 
réaliser une opération globale de rechercher-remplacer sur vos segments 
nouvellement traduits, tout en ignorant les segments à 100 % d'analogie. 

Exclusion des segments 
ICE (In-Context Exact) des 
résultats de recherche 

Dans le panneau Search Options, vous pouvez cocher la case Exclude 
ICE Segments pour exclure des résultats les segments considérés comme 
ICE (analogie parfaite). C'est utile lorsque vous devez vous concentrer 
sur les segments qui ne sont pas d'une analogie exacte. 

Affichage du contexte 

Si vous cliquez avec le bouton droit sur un résultat de recherche et que 
vous sélectionnez See Context dans le menu contextuel, les dix unités 
matériellement trouvés dans le fichier avant et après l'entrée actuelle 
s'affichent dans une fenêtre. 
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Édition de la source 

La commande de menu Tools->Edit Source, également accessible par la 
combinaison de touches Ctrl+Alt+Entrée ou Ctrl+E, vous permet d'ouvrir le 
fichier source auquel appartient l'entrée actuellement sélectionnée. C'est 
très utile pour corriger rapidement une erreur de terminologie détectée 
dans une traduction en cours. Lorsque la source est un fichier SDLX itd, 
Trados TagEditor ttx, Trados Word doc/rtf ou un dossier IBM Translation 
Manager, ApSIC Xbench ouvre le fichier en se positionnant directement 
sur le segment contenant le texte.  

Pour utiliser cette fonction avec IBM Translation Manager, veuillez vous 
assurer que IBM Translation Manager est lancé et qu'il n'existe aucun 
document actuellement en cours d'édition. 

Ce positionnement de ligne est également disponible pour les fichiers 
texte délimité par des tabulations et les mémoires exportées Trados, à 
condition que les paramètres de votre éditeur de texte aient été 
préalablement configurés dans Tools->Settings->Text Editor . Par 
exemple, pour configurer TextPad 4 pour le positionnement de ligne, 
vous devez sélectionner l'exécutable Text Pad et indiquer dans le champ 
Command-Line Parameters les variables suivantes : 
$filename($line,$column). De même, pour configurer Notepad++, vous 
devez sélectionner son exécutable et indiquer dans le champ Command-
Line Parameters les variables suivantes : $filename -n$line. Les autres 
éditeurs de texte peuvent utiliser des variables différentes pour ce champ. 
Veuillez vérifier dans la documentation de votre éditeur de texte les 
arguments appropriés. 

ApSIC Xbench vous permet également un positionnement de segment 
pour le format TMX, à condition que l'éditeur TMX ait été préalablement 
configuré dans Tools->Settings->TMX Editor . Par exemple, pour 
configurer OKAPI Olifant pour le positionnement de segment, vous 
devez sélectionner l'exécutable Olifant et indiquer dans le champ 
Command-Line Parameters les variables suivantes : $Filename 
row=$Segment col=trg edit=yes. Les autres éditeurs TMX peuvent utiliser 
des variables différentes pour ce champ. Veuillez vérifier dans la 
documentation de votre éditeur TMX les arguments appropriés.  

Cette fonction fait d'ApSIC Xbench un outil très utile et très efficace pour 
modifier globalement la terminologie dans ces formats. Si vous souhaitez 
ensuite revenir en arrière et annuler les modifications effectuées, vous 
pouvez recharger le projet ApSIC Xbench avec la commande de menu 
Project->Reload ou View->Refresh. 
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Modèles de recherche 

Les modèles de recherche sont des recherches prédéfinies que vous 
pouvez sélectionner ou exécuter. Pour utiliser un modèle de recherche, 
cliquez sur Search Templates... dans le panneau Search Options, puis 
sélectionnez un modèle de recherche dans la liste. Dans le champ 
Template Source, vous pouvez sélectionner l'affichage de la liste des 
Sample Search Templates, des entrées Project Checklist ou des entrées 
Personal Checklist. Cliquez sur Search pour exécuter directement la 
recherche actuellement sélectionnée, ou cliquez sur le bouton Choose 
pour afficher la définition du modèle de recherche dans les champs 
Source Term et Target Term du panneau Search Options. 
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Exportations des 
éléments 

ApSIC Xbench vous permet d'exporter des éléments du projet dans les 
formats suivants : 

� Fichiers TMX 

� Fichiers texte délimité par des tabulations 

Pour exporter le contenu d'un projet, sélectionnez la commande de menu 
Tools->Export Items. La boîte de dialogue suivante s'affiche : 

 

Dans cette boîte de dialogue, vous pouvez exporter tous les éléments d'un 
projet, tous les éléments de la requête actuelle, uniquement les éléments 
affichés dans la requête actuelle (par exemple, si vous êtes en mode 
aperçu, seuls quelques éléments sont affichés pour chaque niveau de 
priorité), ou tous les éléments d'un glossaire appartenant au projet. 

Si vous le souhaitez, vous pouvez supprimer les répétitions (éléments 
dont les valeurs source et cible sont strictement identiques) des données 
exportées pour réduire la taille du fichier obtenu. Vous pouvez également 
exclure les segments ICE (analogie parfaite) de l'exportation. 

En outre, vous pouvez limiter l'exportation aux seuls éléments non 
traduits (par exemple pour faciliter l'alimentation d'un système de 
traduction automatique) ou aux seuls éléments traduits. Si vous choisissez 
d'exporter uniquement les éléments traduits, vous pouvez en plus indiquer 
si vous souhaitez exporter uniquement les éléments prétraduits (c'est-à-
dire les éléments récupérés d'une mémoire de traduction) ou les éléments 
nouvellement traduits. 
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Lors de l'exportation dans un fichier texte délimité par des tabulations, il 
est possible d'ajouter une ligne d'en-tête.  

Lors de l'exportation dans un fichier TMX, il est possible d'indiquer les 
langues source et cible. Vous pouvez indiquer n'importe quelle valeur dans 
ces champs. Si vous ne connaissez pas les codes linguistiques 
correspondants, vous pouvez cliquer sur le bouton Points de suspension (...) 
pour ouvrir une fenêtre d'aide permettant de sélectionner la langue et le pays.  

 

Si vous travaillez normalement avec un ensemble limité de fichiers, vous 
pouvez cliquer sur le bouton flèche de la liste déroulante pour afficher les 
langues récemment utilisées. 
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Travailler avec des 
traductions en cours 

ApSIC Xbench vous permet de définir n'importe quel fichier comme 
traduction en cours dans la fenêtre Project Properties. 

Par défaut, lorsqu'ils sont ajoutés à un projet ApSIC Xbench, les types de 
fichier suivants sont considérés comme traduction en cours et la case 
Ongoing Translation est cochée : 

� XLIFF 

� Trados TagEditor 

� Trados Word 

� Trados Studio 

� SDLX. Remarque : cette option nécessite que SDLX soit installé sur 
l'ordinateur.  

� STAR Transit 2.6/XV 

� PO 

� Dossier IBM TM 

� Dossier OpenTM2 

� Wordfast TXML 

� Déjà Vu / Idiom 

� Logoport RTF 

Lorsqu'un fichier ou un répertoire est défini comme traduction en cours, 
les deux fonctions suivantes sont activées : 

� Les traductions identifiées comme nouvelles (autres que les analogies 
à 100 %) sont signalées par un petit point rouge ( ). Les traductions 
identifiées comme analogies à 100 % dans la traduction en cours sont 
signalées par un petit cercle rouge ( ). Ces symboles vous permettent 
de savoir immédiatement si le terme provient de vous, ou s'il était 
déjà présent dans la mémoire existante. Cette fonction vous aide à 
prendre des décisions terminologiques, par exemple si vous voulez 
réviser la traduction à la recherche d'un terme et que vous souhaitez 
vous assurer que ce terme n'a pas déjà été utilisé dans la mémoire de 
traduction officielle, utilisée pour prétraduire votre projet. 

� Les segments non traduits s'affichent après les segments traduits. 
C'est particulièrement utile pour décider de la terminologie à utiliser 
pour un nouveau terme, en observant de quelle façon il apparaît dans 
les futures segments de votre propre traduction. De cette façon, vous 
pouvez vous assurer que la traduction choisie pour ce terme 
correspondra bien à toutes les instances de votre projet en cours. 
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Remarque : les glossaires définis comme traduction en cours 
(normalement un seul par projet, mais il est possible d'en ajouter d'autres) 
s'affichent en gras dans la fenêtre Project Properties. 

En outre, les fichiers définis comme traduction en cours peuvent être 
traités par les puissantes fonctions QA d'ApSIC Xbench. 

 



 

 41 

 

Termes clés 

ApSIC Xbench vous permet de définir un ou plusieurs fichiers comme 
termes clés. Pour ce faire, lorsque la liste des glossaires est affichée dans 
la fenêtre Project Properties, cochez la caseKey Terms pour le glossaire 
concerné. Une étoile verte s'affiche à côté de son entrée, comme illustré 
sur la capture d'écran ci-dessous, afin d'indiquer que ce glossaire 
appartient à la catégorie des termes clés. 

 

Lorsqu'un fichier est défini comme terme clé, ses entrées s'affichent avec 
une étoile en tête des résultats. La couleur de l'étoile indique si le terme 
clé est une analogie parfaite (étoile verte ), une analogie parfaite à 
l'exception de la casse (étoile jaune ) ou si le texte recherché est 
simplement présent dans le terme clé (étoile blanche ). 

L'exemple ci-dessous montre les entrées « clipboard » et « Clipboard 
Viewer », qui sont signalées comme termes clés : 
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Dans l'exemple ci-dessus, l'étoile verte de l'entrée « clipboard » signifie 
qu'il s'agit d'une analogie parfaite. L'étoile blanche de l'entrée « Clipboard 
viewer » signifie que le mot recherché fait partie du terme clé. 

Les fonctions QA utilisent également les termes clés définis pour le projet 
en signalant s'ils ont été utilisés dans la traduction en cours. 

 

 

 



 

 43 

 

ApSIC Xbench dispose de fonctions d'assurance qualité (QA), permettant 
d'effectuer des contrôles avancés sur les fichiers définis comme 
traduction en cours. Les fonctions QA ont pour objectif de détecter les 
segments présentant les problèmes suivants : 

� Segments non traduits 

� Segments dont le texte source est identique mais le texte cible est 
différent 

� Segments dont le texte source est différent mais le texte cible est 
identique 

� Segments dont le texte cible est identique au texte source 

� Segments contenant des erreurs de balisage 

� Segments contenant des erreurs numériques 

� Segments contenant des double-espaces 

� Segments qui divergent des termes clés du projet 

� Segments qui correspondent aux conditions de recherche des entrées 
dans la liste de vérification de projet ou personnelle. Consultez la 
section « Gestion des listes de vérification » pour en savoir davantage 
sur cette fonction. 

  

Les fonctions d'assurance qualité s'exécutent dans l'onglet QA de la 
fenêtre principale. L'onglet QA permet d'utiliser les fonctions suivantes : 

Exécutez toutes les vérifications sélectionnées dans Check Group et List 
of Checks en cliquant sur le bouton Check Ongoing Translation. Par 
défaut, toutes les vérifications sont sélectionnées, à l'exception de Target 
same as Source. 

� Exécutez uniquement les vérifications définies dans les listes de 
vérification de projet en cliquant sur le bouton Run Project 
Checklists. 

� Exécutez uniquement les vérifications définies dans les listes de 
vérification personnelles en cliquant sur le bouton Run Personal 
Checklists. Pour modifier les listes de vérification personnelles 
actuelles, utilisez la commande de menu Tools->Manage Checklists. 

Travailler avec les fonctions d'assurance 
qualité 
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� Exportez ensuite les résultats QA affichés, en cliquant avec le bouton 
droit et en sélectionnant Export QA Results dans le menu 
contextuel, dans les formats suivants : HTML, texte délimité par des 
tabulations, Excel ou XML. 

Remarque : veuillez ne pas oublier que la licence d'ApSIC Xbench ne 
vous autorise pas à effacer le cadre promotionnel situé dans l'angle 
supérieur droit du rapport d'exportation QA. Nous avons essayé de rendre 
ces informations aussi discrètes que possible, afin d'éviter un insert du 
type dites-le-à-un-ami ou un cadre plus intrusif encore, pour faire la 
promotion du produit parmi nos pairs.  

Les résultats s'affichent dans le corps de la fenêtre de l'onglet QA. Avec 
certains formats de fichier, vous pouvez depuis ApSIC Xbench ouvrir 
directement le fichier au niveau du segment affiché pour le corriger, en 
sélectionnant la commande de menu Tools->Edit Source ou en appuyant 
sur la combinaison de touches Ctrl+E. 

Vous pouvez limiter la portée des segments pris en compte par le contrôle 
QA en cochant les cases New Segments Only ou Exclude ICE 
Segments.  

Vous pouvez également rendre les vérifications sensibles à la casse en 
cochant la case Case-sensitive Inconsistencies. 

Vous pouvez ignorer le contenu des balises dans les segments lors du 
contrôle QA en cochant la case Ignore Tags. Cela vous permet de 
rechercher des incohérences dans les segments qui présentent le même 
contenu source et cible, à l'exception du contenu des balises internes. 

Dans cette fenêtre, vous pouvez également marquer une erreur en 
cliquant avec le bouton droit sur l'élément concerné et en sélectionnant 
Mark/Unmark Issue dans le menu contextuel. Vous pouvez alors 
optionnellement afficher ou masquer les erreurs marquées en cochant les 
boutons radio Show Marked ou Hide Marked dans le groupe Filter 
Issues, afin de limiter le nombre d'erreurs affichées. Remarque : la 
commande Export QA Results exporte uniquement les erreurs affichées 
(les erreurs masquées ne sont donc pas exportées). 
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Gestion des listes de 
vérification 

Les listes de vérification représentent une fonction d'assurance qualité 
(QA) très utile dans ApSIC Xbench. S'appuyant sur le moteur de 
recherche d'ApSIC Xbench, les listes de vérification regroupent des 
ensembles de recherches qui peuvent être exécutées par lot, afin 
d'identifier les segments contenant des erreurs. Généralement, les listes 
vous servent à stocker des pièges communs, comme les expressions et les 
mots interdits. Compiler les exigences de vos clients dans des listes de 
vérification vous permet de n'oublier aucune vérification, et d'assurer la 
conformité de vos futures traductions. 

Dans l'onglet QA de la fenêtre principale, vous pouvez exécuter ces listes 
de vérification sur tous les fichiers définis comme traduction en cours 
dans le projet ApSIC Xbench. 

Puisque les listes de vérification reposent sur le moteur de recherche 
d'ApSIC Xbench, n'importe quelle requête dans ApSIC Xbench peut être 
ajoutée à une liste de vérification. En fait, l'un des moyens pratiques d'ajouter 
une requête dans la liste de vérification consiste d'abord à exécuter la 
recherche dans l'onglet Project, puis à cliquer sur Add Last Search to 
Checklist dans le panneau Search Options de la fenêtre principale. 

Il existe deux types de listes de vérification : Project Checklist et 
Personal Checklist. 

La « liste de vérification de projet » est sauvegardée avec le fichier de 
projet ApSIC Xbench (extension .xbp) et elle contient normalement les 
requêtes spécifiques au projet, comme la vérification des mots clés non 
traduisibles qui auraient pu être accidentellement traduits.  

La « liste de vérification personnelle » n'est pas sauvegardée dans le 
fichier de projet ApSIC Xbench. À la place, elle est enregistrée dans un 
fichier de liste de vérification ApSIC Xbench (extension .xbckl). ApSIC 
Xbench mémorise les dernières listes de vérification personnelles 
utilisées dans les projets. Vous pouvez charger simultanément autant de 
listes de vérification personnelles que vous le voulez. Les listes de 
vérification personnelles contiennent généralement des requêtes non 
spécifiques à un projet, comme les fautes d'orthographe ignorées par 
votre correcteur orthographique ou une règle linguistique générique qu'il 
faut vérifier à chaque projet. Ces listes sont appelées « personnelles » car 
les requêtes compilées dans ces listes sont composées des erreurs 
particulières qu'un traducteur donné est susceptible de faire. 

Les listes de vérification sont gérées dans la boîte de dialogue Checklist 
Management. Cette boîte de dialogue Checklist Management est 
accessible des deux façons suivantes : 
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� Sélectionnez la commande de menu Tools->Manage Checklists. 

� Cliquez sur l'icône Manage Checklists dans la barre d'outils. 

La boîte de dialogue Checklist Management vous permet de travailler 
sur les listes de vérification de projet et personnelles. 

 
 
Dans la boîte de dialogue Checklist Management, vous pouvez créer 
une nouvelle liste de vérification personnelle en sélectionnant la 
commande de menu Checklist->New après avoir sélectionné le groupe 
Personal Checklists dans l'arborescence de navigation. Vous pouvez 
également ajouter une liste de vérification existante avec la commande de 
menu Checklist->Add. Toutes les listes de vérification personnelles 
listées dans le groupe Personal Checklist seront exécutées lorsque vous 
cliquerez sur Run Personal Checklists ou Check Ongoing Translation 
dans l'onglet QA. 

La liste de vérification <Project> est enregistrée dans le fichier de projet 
ApSIC Xbench (extension .xbp) et elle ne peut pas être supprimée du 
groupe Project Checklists dans l'arborescence de navigation. Vous pouvez 
ajouter d'autres listes de vérification dans le groupe Project Checklist, qui 
seront exécutées lorsque vous cliquerez sur Run Project Checklists ou 
Check Ongoing Translation dans l'onglet QA. Les requêtes de ces listes 
de vérification de projet supplémentaires ne seront pas enregistrées dans le 
fichier de projet ApSIC Xbench lui-même, mais elles seront liées au projet 
et, par conséquent, elles s'afficheront ici de nouveau lors de la prochaine 
ouverture de ce fichier de projet ApSIC Xbench. 

Les requêtes de la liste de vérification sélectionnée dans l'arborescence de 
navigation s'affichent dans le corps de la fenêtre. Vous pouvez les classer 
selon n'importe quelle colonne. Si vous souhaitez désactiver une requête 
individuelle dans la liste de vérification affichée, il vous suffit de 
décocher la case correspondante.  
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Veuillez noter que l'état coché / non coché est enregistré sur le disque 
lorsque vous sauvegardez la liste de vérification et, par conséquent, la 
requête restera en l'état lors de la prochaine ouverture de cette liste de 
vérification. 

Les requêtes des listes de vérification personnelles peuvent être ajoutées 
ou modifiées. Les champs disponibles sont les mêmes que ceux du 
panneau Search Options dans l'onglet Project. 

  

En outre, vous pouvez également sélectionner une catégorie pour chaque 
requête de la liste de vérification en cochant la case Category. Vous 
pouvez indiquer ici n'importe quel nom de catégorie. Si vous souhaitez 
utiliser un nom de catégorie précédemment défini, vous pouvez le 
sélectionner dans la liste déroulante qui s'affiche en cliquant sur le bouton 
flèche. Si vous avez créé des noms de catégorie, vous pourrez exécuter 
certains sous-ensembles de catégorie lors de l'exécution d'une liste de 
vérification de projet ou personnelle, depuis l'onglet QA, en utilisant les 
boutons Run Project Checklist ou Run Personal Checklist. 

Vous pouvez également définir des relations d'héritage entre les listes de 
vérification. Lorsqu'une liste de vérification hérite d'une autre, toutes les 
requêtes sont héritées. Une liste de vérification peut hériter de plusieurs 
autres listes de vérification. 
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Pour hériter d'une liste de vérification, procédez comme suit : 

1. Sélectionnez la commande de menu Edit ->Inheritance->Add->Local 
(ou cliquez sur le bouton Inheritance, puis cliquez avec le bouton droit 
sur la liste des requêtes héritées qui s'affichent et sélectionnez Add-
>Local). 

2. Saisissez un nom pour la liste de vérification héritée et choisissez un 
nom de fichier. Le nom indiqué ici peut être différent du nom affiché 
pour la liste de vérification. 

 

3. Ajoutez n'importe quelle liste de vérification en suivant les étapes 1 et 

2. La boîte de dialogue affichera les requêtes héritées avec l'icône . 
Vous pouvez écraser ces requêtes héritées mais vous ne pouvez pas les 
modifier ou les supprimer. 
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Après avoir défini une relation d'héritage, toute modification ou addition 
dans la liste de vérification parent sera héritée. 

La liste de vérification de projet est sauvegardée automatiquement 
lorsque vous enregistrez le projet. Si vous ajoutez des requêtes à la liste 
de vérification de projet et que vous fermez ApSIC Xbench, un message 
vous demandera de sauvegarder le projet. 

Si vous cliquez sur Apply  dans cette boîte de dialogue, les modifications 
effectuées dans toutes les listes de vérification seront sauvegardées (à 
l'exception de la liste de vérification <Project> qui sera enregistrée dans 
le fichier de projet. Si vous cliquez sur OK , les modifications seront 
également sauvegardées et la fenêtre sera fermée. 
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Les sections suivantes vous présentent des informations complémentaires 
sur les fonctionnalités d'ApSIC Xbench. 

 

Informations complémentaires 
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Configuration des 
paramètres d'ApSIC Xbench 

Dans le menu Tools, cliquez sur Settings pour ouvrir la boîte de dialogue 
Settings, illustré sur la capture d'écran ci-dessous. 

 

Dans cette boîte de dialogue, vous pouvez configurer ApSIC Xbench 
pour qu'il se lance toujours en mode plein écran (recommandé) et vous 
pouvez également modifier les combinaisons de touches par défaut, 
disponibles dans l'ensemble du système. Remarque : ne modifiez les 
combinaisons de touches que si elles rentrent en conflit avec d'autres 
applications utilisant les mêmes combinaisons. 

Les différents paramètres de cette boîte de dialogue sont détaillés ci-
dessous : 

Maximize on Startup. Si vous cochez cette case, ApSIC Xbench se 
lancera au démarrage en plein écran. Il est recommandé de cocher cette 
case, car le plein écran est le mode d'affichage qui fournit simultanément 
la plus grande quantité d'informations. 

Maximum Entries per Level in Overview Mode. Le mode aperçu 
n'affiche que quelques entrées pour chaque niveau de priorité. Indiquez 
ici le nombre maximal d'entrée pour un niveau. Cependant, après une 
recherche, si vous souhaitez afficher toutes les entrées tout en préservant 
les différents niveaux de priorité, vous pouvez utiliser le lien bleu « Click 
here to show all matches » qui s'affiche sous le panneau des résultats, du 
côté droit.  

Les paramètres suivants appartiennent au groupe Hotkeys.  

C H A P I T R E  1 2  



 

54 Utilisation d'ApSIC Xbench  

 

Disable. Lorsque cette case est cochée, elle vous permet de désactiver la 
fonction d'ApSIC Xbench relatives aux combinaisons de touches 
disponibles dans l'ensemble du système. Il est recommandé de ne pas 
cocher cette case, car c'est l'une des fonctions les plus utiles d'ApSIC 
Xbench, qui permet de lancer une recherche à partir de n'importe quelle 
application. 

Source Hotkey. C'est la combinaison de touches définie pour lancer 
une recherche sur le contenu du presse-papiers dans le texte source. 
La combinaison par défaut est Ctrl+Alt+Inser. 

Target Hotkey. C'est la combinaison de touches définie pour lancer 
une recherche inverse sur le contenu du presse-papiers dans le texte 
cible. La combinaison par défaut est Ctrl+Alt+Retour arrière. 

Automatic Substitution Hotkey. C'est la combinaison de touches 
définie pour remplacer automatiquement le texte cible dans l'éditeur 
de traduction. Cette combinaison est conçue pour récupérer 
automatiquement les traductions. Les conditions requises de cette 
substitution automatique sont les suivantes :  

� Le terme cible doit correspondre exactement au terme recherché. 

� Il ne doit exister qu'une et une seule variante du terme recherché. 

Si l'une des conditions ci-dessus n'est pas respectée, le comportement 
de cette combinaison de touches sera identique à celui de la 
combinaison Source Hotkey. 

Il est recommandé de ne pas modifier ces combinaisons de touches, 
sauf si elles rentrent en conflit avec d'autres applications. 

Internet Hotkeys / Open in default browser. Lorsque cette case est 
cochée, les requêtes Internet associées à des combinaisons de touches 
(par exemple, Ctrl+Alt+1 ou Ctrl+Alt+2) s'ouvrent dans le navigateur 
par défaut, au lieu de s'ouvrir dans le navigateur interne d'ApSIC 
Xbench. Par exemple, si la première entrée configurée des liens 
Internet définis pointe sur Google, vous pouvez utiliser cette fonction 
pour rechercher le texte marqué directement dans Google, en utilisant 
simplement la combinaison de touches Ctrl+Alt+1. 

Transfer Method. ApSIC Xbench utilise le presse-papiers comme 
mécanisme de transfert entre les différentes applications Windows et 
ApSIC Xbench. Normalement, la méthode de transfert la plus 
pratique et la plus compatible est celle définie par défaut avec Copy 
Message et Manual Paste, mais pour certaines applications (comme 
celles qui n'utilisent pas les combinaisons de touches standard pour 
copier-coller), vous pouvez modifier ces paramètres pour tirer un 
meilleur parti d'ApSIC Xbench. 

Les options de la méthode de transfert disponibles pour Input  sont les 
suivantes : 
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Copy Message. Lorsque vous appuyez sur la combinaison de touches 
Ctrl+Alt+Inser, ApSIC Xbench envoie un message COPIER à 
l'application afin de copier le texte sélectionné dans le presse-papiers, 
puis il exécute une recherche en utilisant le contenu du presse-
papiers. Un nombre limité d'applications prend en charge cette 
technique, mais elle a l'avantage d'éviter d'avoir à copier 
manuellement le texte dans le presse-papiers (normalement avec la 
combinaison de touche Ctrl+Inser). 

Manual Copy. Avec cette option, ApSIC Xbench s'attend à ce que 
l'utilisateur ait déjà copié le texte à rechercher dans le presse-papiers. 
Cela semble plus fastidieux, mais cette technique a l'avantage que de 
nombreuses applications prennent en charge la combinaison de 
touches Ctrl+Inser pour la copie de texte, ce qui signifie que vous 
bénéficierez d'un comportement plus cohérent à travers vos 
différentes applications. L'inconvénient, si l'application d'édition 
présente un long temps de réponse, c'est que vous pouvez aller trop 
vite avec la combinaison Ctrl+Inser, Ctrl+Alt+Inser pour l'application. 

Keyboard Emulation (Ctrl+Inser) . Avec cette option, ApSIC 
Xbench envoie la combinaison de touches Ctrl+Inser à l'application 
d'édition, puis exécute la recherche. De cette façon, l'utilisateur n'a 
pas besoin de taper manuellement la combinaison de touches 
Ctrl+Inser avant la recherche. Certaines applications peuvent ne pas 
prendre en charge cette option. 

Keyboard Emulation (Ctrl+C) . Avec cette option, ApSIC Xbench 
envoie la combinaison de touches Ctrl+C à l'application d'édition, puis 
exécute la recherche. De cette façon, l'utilisateur n'a pas besoin de 
taper manuellement la combinaison de touches Ctrl+C avant la 
recherche. Certaines applications peuvent ne pas prendre en charge 
cette option. 

Les options de la méthode de transfert disponibles pour Output  et 
Automatic Substitution Output  sont les suivantes : 

Paste Message. Lorsque vous appuyez sur la touche Entrée pour 
sélectionner une traduction, ApSIC Xbench envoie le message 
COLLER à l'application afin de coller la traduction. Un nombre 
limité d'applications prend en charge cette technique, mais elle a 
l'avantage d'éviter d'avoir à coller manuellement le texte dans le 
presse-papiers (normalement avec la combinaison de touche 
Maj+Inser). 

Manual Paste. Avec cette option, ApSIC Xbench copie le texte cible 
de l'entrée sélectionnée dans le presse-papiers, si vous appuyez sur la 
touche Entrée pour sélectionner une traduction. L'utilisateur est 
supposé appuyer sur la combinaison de touches Maj+Inser (ou la 
combinaison de touches correspondante pour coller le texte dans 
l'application). C'est l'option recommandée par défaut, pour des raisons 
de compatibilité avec les applications. 

Keyboard Emulation. Avec cette option, ApSIC Xbench envoie le 
texte cible en simulant la saisie du texte dans l'application d'édition, 
lorsque vous sélectionnez une entrée et que vous appuyez sur la 
touche Entrée pour copier la sélection dans le presse-papiers. 
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Keyboard Emulation (Ctrl+V) . Avec cette option, ApSIC Xbench 
envoie le texte cible en simulant la combinaison de touches Ctrl+V 
dans l'application d'édition, lorsque vous sélectionnez une entrée et 
que vous appuyez sur la touche Entrée pour copier la sélection dans le 
presse-papiers. 

Cliquez sur l'onglet Colors de cette boîte de dialogue pour modifier les 
couleurs par défaut de la fenêtre principale. La fenêtre suivante s'affiche : 

 

Les options de cet onglet sont les suivantes : 

Background color when zoomed. L'affichage dans ApSIC Xbench 
utilise deux modes : le mode aperçu où quelques entrées de chaque 
niveau de priorité s'affichent, et le mode zoom où toutes les entrées d'un 
niveau de priorité donné s'affichent. Cette option définit la couleur 
d'arrière-plan utilisée en mode zoom, qui sert d'indicateur pour signaler 
que vous n'êtes pas en mode aperçu (qui est le mode par défaut). 

Key Terms priority . C'est la couleur utilisée pour les entrées qui 
appartiennent au niveau de priorité des termes clés. Un glossaire est 
défini comme terme clé dans Project->Settings. 

High Priority . C'est la couleur utilisée pour les entrées qui appartiennent 
au niveau de priorité haute.  

Medium Priority . C'est la couleur utilisée pour les entrées qui 
appartiennent au niveau de priorité moyen. 

Low Priority . C'est la couleur utilisée pour les entrées qui appartiennent 
au niveau de priorité basse. 

Background color when nothing found. C'est la couleur d'arrière-plan 
utilisée dans le champ de recherche lorsqu'aucune entrée n'est trouvée. 
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Cliquez sur l'onglet Internet  pour définir les URL de recherche sur 
Internet : 

 

L'onglet Internet  vous permet de définir les modèles d'URL à utiliser 
pour exécuter des recherches ciblées sur Internet, par exemple dans un 
dictionnaire en ligne. Vous pouvez utiliser autant d'entrées que vous le 
souhaitez, mais seules les 10 premières bénéficieront d'une combinaison 
de touches définie, sous la forme Alt+n dans ApSIC Xbench, ou 
Ctrl+Alt+n (avec les touches du pavé numérique en mode Verr Num dans 
ce dernier cas), depuis n'importe quelle application Windows. n peut être 
un chiffre de 0 à 9, où 0 correspond à la 10e entrée de la liste. 

Vous pouvez utiliser les boutons Up et Down pour déplacer l'entrée dans 
la liste vers le haut ou le bas. Sur le site d'ApSIC, une bibliothèque d'URL 
est disponible et prête à l'emploi. 

Les 10 premières entrées, bénéficiant d'une combinaison de touches, 
apparaissent dans le menu Internet . 

Vous pouvez utiliser la commande de menu Internet ->Capture URL 
pour insérer des URL dans cette liste. 

L'onglet Miscellaneus Settings vous permet de définir un contrôle 
hebdomadaire des mises à jour d'ApSIC Xbench, et d'activer la fonction 
de projet alternatif. 
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Les options de cet onglet sont les suivantes : 

Check weekly for new versions. Si cette case est cochée, ApSIC Xbench 
vérifiera une fois par semaine si des mises à jour sont disponibles. 

Enable alternative project. Si cette case est cochée, ApSIC Xbench 
conservera en mémoire le projet précédemment ouvert, simultanément 
avec le projet en cours. Pour basculer d'un projet à l'autre, utilisez la 
commande de menu Project->Switch to Alternative Project. Pour 
désactiver le projet alternatif et libérer la mémoire utilisée, utilisez la 
commande de menu Projects->Forget Alternative Project. 

Load last project when ApSIC Xbench starts. Si cette case est cochée, 
au prochain lancement d'ApSIC Xbench, le dernier projet ouvert lors de 
la session précédente sera rechargé. 

Show warning when copying fuzzy match. Lorsque cette case est 
cochée, ApSIC Xbench affichera un message d'alerte si vous appuyez sur 
la touche Entrée pour copier l'entrée actuellement sélectionnée dans les 
résultats de recherche, et que ladite entrée ne correspond pas exactement 
au terme recherché. 

Show warning when shutting down. Lorsque cette case est cochée, 
ApSIC Xbench affichera un message d'alerte si vous fermez le 
programme. 

Default Project Directory. Ce champ vous permet de définir le dossier 
par défaut de vos projets ApSIC Xbench. 
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L'onglet Text Editor  vous permet de configurer des arguments en ligne 
de commande pour le lancement d'un éditeur de texte particulier, lorsque 
vous utilisez la fonction Edit Source dans les résultats de recherche ou 
avec la fonction QA, pour un glossaire au format .txt. Cela comprend les 
fichiers texte délimité par des tabulations, les mémoires exportées 
Trados, les mémoires Wordfast et les glossaires Wordfast. Lorsque cet 
onglet est correctement configuré, le fichier s'ouvre directement à la ligne 
du segment sélectionné lors de l'utilisation de la commande Edit Source.  

 

Si vous choisissez de définir un éditeur de texte, vous devez remplir les 
champs suivants : 

� Path to Executable. C'est le chemin du fichier .exe de l'éditeur de 
texte. Vous pouvez cliquer sur le bouton Points de suspension (...) 
pour sélectionner le fichier exécutable (.exe). 

� Command-line Parameters. Ce champ vous permet de définir les 
arguments de la ligne de commande à envoyer à l'éditeur pour 
l'ouverture du fichier. Vous pouvez utiliser différentes variables, 
qu'ApSIC Xbench remplacera par les valeurs d'argument 
appropriées : 

� $Filename : le nom du fichier, y compris son chemin. 

� $Line : le numéro de ligne du segment dans le fichier texte. Cette 
ligne se réfère à l'emplacement du texte cible. 

� $Column : la colonne dans la ligne, qui se réfère à l'emplacement 
du texte cible. 

� $Segment : le numéro du segment dans le fichier texte. 
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Par exemple, pour configurer TextPad 4 pour le positionnement de 
ligne, vous devez sélectionner l'exécutable Text Pad et indiquer dans 
le champ Command-Line Parameters les variables suivantes : 
$filename($line,$column). De même, pour configurer Notepad++, vous 
devez sélectionner son exécutable et indiquer dans le champ 
Command-Line Parameters les variables suivantes : $filename -
n$line. Les autres éditeurs de texte peuvent utiliser des variables 
différentes pour ce champ. Veuillez vérifier dans la documentation de 
votre éditeur de texte les arguments appropriés. 

L'onglet TMX Editor  vous permet de configurer des arguments en ligne 
de commande pour le lancement d'un éditeur TMX particulier, lorsque 
vous utilisez la fonction Edit Source dans les résultats de recherche ou 
avec la fonction QA, pour un glossaire au format .tmx. Lorsque cet onglet 
est correctement configuré, le fichier s'ouvre directement à la ligne du 
segment sélectionné lors de l'utilisation de la commande Edit Source.  

 

Si vous choisissez de définir un éditeur de texte, vous devez remplir les 
champs suivants : 

� Path to Executable. C'est le chemin du fichier .exe de l'éditeur de 
texte. Vous pouvez cliquer sur le bouton Points de suspension (...) 
pour sélectionner le fichier exécutable (.exe). 

� Command-line Parameters. Ce champ vous permet de définir les 
arguments de la ligne de commande à envoyer à l'éditeur pour 
l'ouverture du fichier. Vous pouvez utiliser différentes variables, 
qu'ApSIC Xbench remplacera par les valeurs d'argument 
appropriées : 

� $Filename : le nom du fichier, y compris son chemin. 

� $Line : le numéro de ligne du segment dans le fichier texte. Cette 
ligne se réfère à l'emplacement du texte cible. 

� $Column : la colonne dans la ligne, qui se réfère à l'emplacement 
du texte cible. 

� $Segment : le numéro du segment dans le fichier texte. 
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Par exemple, pour configurer OKAPI Olifant pour le positionnement 
de segment, vous devez sélectionner l'exécutable Olifant et indiquer 
dans le champ Command-Line Parameters les variables suivantes : 
$Filename row=$Segment col=trg edit=yes. Les autres éditeurs TMX 
peuvent utiliser des variables différentes pour ce champ. Veuillez 
vérifier dans la documentation de votre éditeur TMX les arguments 
appropriés.  
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Astuces rapides pour 
ApSIC Xbench 

Ce chapitre est consacré aux plus importantes fonctions d'ApSIC Xbench 
et a pour objectif de fournir un aperçu rapide des capacités d'ApSIC 
Xbench. 

Nous vous recommandons vivement de lire ce chapitre pour tirer le 
meilleur parti d'ApSIC Xbench avec le minimum d'effort. 

� ApSIC Xbench n'est pas un indexeur. Il lit le contenu des fichiers 
chaque fois que vous chargez un projet et tente de répondre le plus 
vite possible à des requêtes terminologiques. Par conséquent, le 
chargement de tous les glossaires Microsoft pour une langue majeure 
peut prendre plusieurs minutes et nécessitera une quantité 
significative de mémoire vive. Si vous prévoyez de charger des 
volumes de référence importants, de l'ordre de plusieurs dizaines de 
millions de mots, il est fortement recommandé de disposer d'au moins 
1 Go de mémoire. Si votre ordinateur manque de puissance, nous ne 
recommandons pas de charger tous les glossaires Microsoft à la fois, 
mais plutôt une sélection d'entre eux dont les domaines correspondent 
à votre projet de traduction actuel. 

� Une fois lancé, ApSIC Xbench reste actif en arrière-plan jusqu'à ce 
qu'il soit explicitement fermé. Lorsqu'ApSIC Xbench est actif, une 
icône sous la forme d'une gemme rose s'affiche dans la zone de 
notification. Pour décharger ApSIC Xbench de la mémoire, vous 
devez le fermer. Par exemple, vous pouvez le fermer en cliquant avec 
le bouton droit sur l'icône de la zone de notification, puis en 
sélectionnant Shutdown Xbench dans le menu contextuel. 

� Lorsqu'ApSIC Xbench est actif, il est possible de l'appeler depuis 
n'importe quelle application Windows avec la combinaison de touches 
Ctrl+Alt+Inser. Si un texte est sélectionné dans l'application, ApSIC 
Xbench le recherche automatiquement. Les combinaisons de touches 
actuelles sont configurables. 

� En plus des glossaires de logiciels Microsoft, ApSIC Xbench prend 
en charge de nombreux formats d'entrée issus des principales 
applications de TAO, notamment Trados, SDLX, Transit, Wordfast, 
IBM TranslationManager, ainsi que d'autres formats standard 
normalisés comme TMX, TBX ou XLIFF. Vous pouvez combiner ces 
différents formats dans un projet Xbench en attribuant des niveaux de 
priorité à chaque source, afin de définir le processus de décision 
terminologique de votre projet de traduction particulier. Vous pouvez 
sauvegarder chaque projet ApSIC Xbench pour le réutiliser 
ultérieurement. 
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� Vous pouvez copier le texte source de l'élément actuellement 
sélectionné dans le presse-papiers, en appuyant sur la touche Entrée 
dans la fenêtre principale. La touche Entrée ferme la fenêtre tout en 
copiant le texte, afin que vous puissiez le coller dans l'application 
d'édition de votre traduction grâce à la combinaison de touches 
Maj+Inser. C'est très utile lorsque vous traduisez la documentation 
d'un logiciel dont les chaînes textuelles sont chargées dans un projet 
ApSIC Xbench. 

� L'onglet QA permet d'exécuter des contrôles d'assurance qualité. Les 
contrôles QA ne sont disponibles que pour les glossaires définis 
comme traduction en cours. Les listes de vérification sont une 
fonctionnalité QA très puissante, qui permet d'exécuter par lot un 
certain nombre de vérifications prédéfinies tout en bénéficiant des 
capacités de recherche puissantes d'ApSIC Xbench. 

Après vous être familiarisé avec les principales possibilités du 
programme, nous vous encourageons à lire en détail la documentation 
pour en savoir davantage sur les fonctionnalités utiles disponible dans le 
produit. 
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Comment obtenir les 
glossaires de logiciels 
Microsoft et Apple 

Obtention des glossaires 
Microsoft 

Bien que les glossaires de logiciels Microsoft au format .csv aient été 
autrefois accessibles au public à partir du site FTP de Microsoft, ils ne 
sont désormais disponibles qu'à travers un abonnement payant à MSDN, 
à l'heure où nous écrivons. 

Chaque langue dispose d'un fichier .zip indépendant, contenant tous les 
glossaires individuels des logiciels Microsoft localisés dans cette langue. 
La taille de chaque fichier de langue peut être comprise entre 1 et 
100 Mo, voire plus, en fonction du nombre d'applications localisées par 
Microsoft dans la langue concernée. 

Obtention des glossaires 
Apple 

À l'heure où nous écrivons, les glossaires de logiciels Apple Mac OS X 
sont disponibles à l'adresse suivante : 

� http://developer.apple.com/internationalization/downloads/  

� Les glossaires de chaque langue sont au format Macintosh Disk 
Image (extension .dmg). Pour charger des glossaires Mac OS dans 
ApSIC Xbench, il convient au préalable d'extraire les fichiers .ad 
contenus dans ces images disque. Pour ce faire, vous pouvez utiliser 
par exemple le logiciel UltraISO 
(http://www.ezbsystems.com/ultraiso/index.html). 
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ApSIC Xbench vous permet de définir des liens Internet, qui peuvent être 
utilisés pour rechercher des termes sur Internet. ApSIC Xbench dispose 
de son propre navigateur interne mais, en appuyant sur la combinaison de 
touches Ctrl+W, vous pouvez ouvrir dans le navigateur Internet par défaut 
de votre système la page actuellement affiché dans le navigateur d'ApSIC 
Xbench. 

 

Internet 
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Recherche sur Internet 

ApSIC Xbench dispose d'un onglet Internet  qui fournit des chemins 
d'intégration pour certaines sources d'information et de terminologie, 
disponibles sur Internet. L'illustration suivante montre une recherche dans 
Google exécutée dans ApSIC Xbench. 

 

ApSIC Xbench dispose déjà de quelques liens prédéfinis, mais 
l'utilisateur peut modifier ou ajouter de nouveaux liens à volonté. Les 
liens définis sont accessibles par l'une des méthodes suivantes : 

Sélectionnez l'onglet Internet , choisissez la source souhaitée dans le 
champ Website, puis saisissez la chaîne à rechercher dans le champ Text 
to search et appuyez sur la touche Entrée. 

Si ApSIC Xbench est l'application en cours, appuyez sur la combinaison 
de touches Alt+n, où n est un chiffre compris entre 0 et 9. Le 0 correspond 
à la 10e entrée de la liste. Le terme actuel dans le champ Source de 
l'onglet Project, ou dans le champ Text to search de l'onglet Internet , 
est utilisé pour la recherche. Le numéro correspond au numéro séquentiel 
du lien dans la liste accessible par la commande de menu Tools-
>Settings->Internet . 

Depuis n'importe quelle application, sélectionnez le terme recherché et 
appuyez sur la combinaison de touches Ctrl+Inser suivie de la 
combinaison de touches Ctrl+Alt+n, où le chiffre n doit être tapé sur le 
pavé numérique avec le mode Verr Num activé. 
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Définition des liens 
Internet 

Les liens Internet sont définis dans Internet ->Define Links. Les liens 
sont très faciles à définir. Procédez simplement comme suit : 

1 Ouvrez la liste des liens avec la commande de menu 
Internet ->Define Links. Pour créer une nouvelle entrée, il vous 
suffit de déplacer le curseur sous la dernière entrée. 

 

2 Effectuez une recherche dans le site web que vous souhaitez vérifier. 
Par exemple, lancez une recherche dans Google sur le terme 
« xbench ». 

3 Copiez ensuite l'URL dans le presse-papiers, par exemple : 

http://www.google.com/search?hl=en&lr=&ie=UTF-8&q=xbench 

4 Copiez l'URL dans l'une des entrées de la fenêtre et remplacez le 
terme recherché par la variable %s, comme illustré sur la capture 
d'écran ci-dessous. Lors des futures requêtes utilisant cette chaîne 
d'arguments, ApSIC Xbench remplacera la variable %s par le terme 
recherché. 

5 Attribuez un nom à votre lien en déplaçant le curseur dans la colonne 
Name et saisissez son nom. Ce nom s'affichera dans le champ 
Website de l'onglet Internet , ainsi que dans le menu déroulant 
Internet . 

6 Si vous souhaitez déplacer l'entrée actuelle dans la liste (avec pour 
effet de modifier le numéro de la combinaison de touches 
correspondante), vous pouvez cliquer sur les boutons Up et Down 
situés en bas de la fenêtre. 
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Si vous trouvez un lien intéressant en navigant sur Internet à partir de 
l'onglet Internet d'ApSIC Xbench, vous pouvez rapidement l'ajouter à la 
liste en utilisant la commande de menu Internet ->Capture URL. 

Si la barre d'outils est activée, un certain nombre de boutons s'y affichent 
pour aider à naviguer dans les pages Internet. L'un de ces boutons vous 
permet d'ouvrir Internet Explorer et d'y afficher la page que vous êtes en 
train de consulter. Vous pouvez également utiliser pour ce faire la 
commande de menu Internet ->Open Browser ou encore la combinaison 
de touches Ctrl+W. 

 

 





 

 73 

 

 

Bogues et suggestions 
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Communiquer des 
bogues et des 
suggestions 

Si vous rencontrez des erreurs lors de l'utilisation de ce programme, nous 
vous remercions de nous les signaler. Nous sommes également ouverts à 
toute suggestion qui nous permettrait d'améliorer les fonctionnalités qui 
vous semblent compliquées.  

Veuillez nous communiquer vos bogues ou suggestions à l'aide du 
formulaire suivant : http://www.apsic.com/en/products_submit_bug.aspx  

Toute information communiquée restera confidentielle et ne sera utilisée 
que pour résoudre le problème indiqué. 
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